PDA

Просмотр полной версии : ошибка в плагине Automacro


Takamekito Kirukato
12.04.2010, 20:36
сегодня понадобилось условие zeny или переменная $.zeny, выяснилось что в последней сборке (версия макрос плагина 2.0.2) оно не работает, чуток покапавшись заработало, косяк разработчиков:

Automacro.pm

- foreach my $i (@{$automacro{$am}->{zeny}}) {next CHKAM unless checkCond($char->{zenny}, $i)}

+ foreach my $i (@{$automacro{$am}->{zeny}}) {next CHKAM unless checkCond($char->{zeny}, $i)}

Utilities.pm
- $varStack{".zeny"} = $char->{zenny};
+ $varStack{".zeny"} = $char->{zeny};

manticora
12.04.2010, 20:53
Да, знакомая фишка. Только последняя версия макроплагина - 2.0.3 и в ней этот баг был исправлен, насколько я помню.

Takamekito Kirukato
12.04.2010, 20:56
возможно:) просто качал позавчера свнскую версию, там был этот плагин.

4epT
12.04.2010, 21:23
а ты макро-плагин сам тоже с СВН качал? или откуда из сборки взял?

Takamekito Kirukato
12.04.2010, 21:30
сдул отсюда _http://openkore.collectskin.com/openkore_ready.zip

4epT
12.04.2010, 23:09
открою секрет.. в этом файле вообще нету папки plugins :)

Takamekito Kirukato
13.04.2010, 06:19
хы, угу, значит плагины где то с другого места стащил.

4epT
13.04.2010, 21:27
ну так вот просто плагин у тебя старый получился.. не для этой сборки