PDA

Просмотр полной версии : бот не хочет ходить


sunwell
26.03.2008, 00:45
помогите разобраться, почему бот не хочет ходить.стоит на месте и бьет только подбегающих к нему мобов, но по конфигу должен ходить...

master Dolarm_Lands
ip 80.86.89.251
port 6900
master_version 2
version 19
serverType 5
serverEncoding Russian
charBlockSize 108


username *****
password *****
char 3


lockmap lhz_dun02


attackAuto 2
attackAuto_party 1
attackAuto_onlyWhenSafe 0
attackAuto_followTarget 1
attackAuto_inLockOnly 1
attackDistance 1.5
attackDistanceAuto 0
attackMaxDistance 2.5
attackMaxRouteDistance 100
attackMaxRouteTime 4
attackMinPlayerDistance 2
attackMinPortalDistance 4
attackUseWeapon 1
attackNoGiveup 0
attackCanSnipe 0
attackCheckLOS 0
attackLooters 0
aggressiveAntiKS 0

runFromTarget 0
runFromTarget_dist 6


}
useSelf_skill Heal {
lvl 10
hp < 80 %
sp > 10 %
}
partySkill Blessing {
lvl 10
target_whenStatusInactive Blessing
}
useSelf_skill Dangerous Soul Collect {
lvl 1
spirit < 1
notWhileSitting 1
}

4epT
26.03.2008, 01:09
как у нас дела обстоят с "route_escape_randomWalk" и "lockMap"??

sunwell
26.03.2008, 11:14
спасибо за помощь, мне нужно было вставить эту строчку
route_escape_unknownMap 1
route_escape_reachedNoPortal 1
route_escape_randomWalk 1
route_randomWalk 1
route_randomWalk_inTown 0
route_randomWalk_maxRouteTime 75
route_maxWarpFee
route_maxNpcTries 5
route_teleport 0
route_teleport_minDistance 150
route_teleport_maxTries 8
route_teleport_notInMaps
route_step 15

Женя
26.03.2008, 13:38
Строчку рандомно определять самим?)

%u0410%u043D%u0442%u0438%
15.06.2008, 18:32
Хм, сори я ламер, я скопировал конфиг из данного топика и бот у меня убегает из локи
конкретно вот эту часть:
route_escape_unknownMap 1
route_escape_reachedNoPortal 1
route_escape_randomWalk 1
route_randomWalk 1
route_randomWalk_inTown 0
route_randomWalk_maxRouteTime 75
route_maxWarpFee
route_maxNpcTries 5
route_teleport 0
route_teleport_minDistance 150
route_teleport_maxTries 8
route_teleport_notInMaps
route_step 15
что изменить, что бы он не убегал?
А то я смотрел пояснения, что за что отвечает из других топиков и всё равно невпиливаю....(

smetannik
16.06.2008, 02:23
Добрый вечер.

У меня возникла та же проблема. Коннектится к серверу, юзает скилы, но не ходит, может это быть из-за того что я тестил его в данже ?
При запуске выводит ошибку:

Cannot load field pay_dun01
....
Invalid coordinates specified for lockMap coordinates are unwalkable


attackAuto 2 - стоит двойка


lockMap pay_dun01
lockMap_x
lockMap_y
lockMap_randX
lockMap_randY

route_escape_unknownMap 1
route_escape_reachedNoPortal 1
route_escape_randomWalk 1
route_randomWalk 1
route_randomWalk_inTown 0
route_randomWalk_maxRouteTime 75
route_maxWarpFee
route_maxNpcTries 5
route_teleport 0
route_teleport_minDistance 150
route_teleport_maxTries 8
route_teleport_notInMaps
route_step 15

runFromTarget 0
runFromTarget_dist 6

saveMap payon
saveMap_warpToBuyOrSell 0
saveMap_warpChatCommand

shopAuto_open 0
shop_random 0

B@R@B@SHK@
16.06.2008, 10:08
поиск рулезз..
Настраивайте lockmap
чтобы бот с локи не убегал

smetannik
16.06.2008, 10:46
он у меня вообще не двигается )

alex600
16.06.2008, 13:54
Cannot load field pay_dun01
Потому и не ходит. Качай бота заново.

smetannik
16.06.2008, 20:42
Все разобрался, качал бота с офф сайта опенкора, там у них набор карт отдельно качается

%u0410%u043D%u0442%u0438%
17.06.2008, 10:47
LockMap prt_fild04
lockMap_x
lockMap_y
lockMap_randX
lockMap_randY

так это тоже есть, всёравно убегает(